Results 1 to 6 of 6

Thread: Dual Tank Soda Blaster problems....

  1. #1

    Angry Dual Tank Soda Blaster problems....

    Hello - It's 2pm here on the west coast... after 5 on the east so NO customer service for you... Didn't get a call back today after leaving a message yesterday either.

    Anyway - First real day using my dual tank blaster - Let's see, the abrasive side hose blew out. The hose clamp broke while reattaching the hose...And the green control knob on the deadman gun broke off. Also the screw bolt holding the red handle on fell out and was stripped.

    Oh and because this thing clogs up a lot - even with fresh desiccant, the nozzle threads are all messed up from repeated removal.

    All in 1 day. I'm ready to take the blaster out to the dumpster and throw it in.

    Let's see, I need a new hose, new soda knob, new nozzle, and a day of frustration back.

  2. #2
    Join Date
    Dec 2004
    Location
    Pottstown, PA
    Posts
    869

    Default

    If you haven't heard from anyone, shoot me a pm with your information (name & telephone) and I'll make sure you are contacted Monday. I apologize that no one got back to you and for the issues you are having with your blaster.

  3. #3

    Default

    Nick - I sent you a PM.

    Also, today was a better day. I completely cleaned out the blaster. Re-cleared all airlines, fresh desiccant in the filter, and cut and reattached the hose. I only had about 5 clogs in an hour and a half.

    Still - I'd expect better quality.

  4. #4

    Default

    Wow - I forgot to update this thread - I had a new problem - the brass Y connector at the deadman handle (attaches both hoses to the handle) had a blow out two days ago. Yeah the abrasive cut a hole in the side of the brass connector and stuff flies everywhere. I have pics.



    Ok Customer service helped me finally (after one person quickly decided I should be sent to technical support voicemail - Danielle) - Anyway, I did not end up getting the correct part. They sent me a T connector and I need a Y connector... - And of course it's after 2pm on the west coast, so nobody is there to answer the phone.

    Another day shot.

    I did go to harbor freight and pick up their best abrasive blaster and made more progress in one day, than I did in 3 days with the eastwood blaster - Sorry but it's the truth.

  5. #5

    Default

    Still don't have a Y connector yet..

    Customer service did send me parts though: A hose, and for some reason two soda control valves (green handle). I still can't use the dual blaster. It's now 5/13/10.

  6. #6
    Join Date
    Dec 2004
    Location
    Pottstown, PA
    Posts
    869

    Default

    Our system is showing that Customer Service sent a "Y" connector out on 5/7 to you. I checked FedEx, and it is tracking to be delivered tomorrow.

Similar Threads

  1. Setting up the soda blaster
    By veritas in forum Ask Eastwood
    Replies: 7
    Last Post: 04-02-2013, 09:36 AM
  2. Soda blaster
    By mtburg71 in forum Ask Eastwood
    Replies: 2
    Last Post: 03-24-2010, 10:07 PM
  3. Problems with the Dual Blaster
    By tattoo collector in forum Ask Eastwood
    Replies: 1
    Last Post: 02-04-2010, 10:09 AM
  4. sand blaster conversion to soda
    By bronson in forum Ask Eastwood
    Replies: 0
    Last Post: 12-01-2009, 09:37 PM
  5. Soda Blaster
    By euchre98 in forum Powder Coating Archives
    Replies: 2
    Last Post: 12-29-2005, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Follow Us